Instalarea PHP5.3 în Ubuntu

php5.3

Foto: sitepoint.com

În varianta de bază, Ubuntu 9.x și 10.04 vine cu PHP 5.2. Dacă totuși aveți nevoie de PHP 5.3 soluția cea mai decentă este folosirea pachetelor PHP 5.3 de la dotdeb.org.

Ok, dotdeb.org este un depozit de aplicații pentru Debian, așa că, pentru a le putea instala în Ubuntu avem nevoie să muncim puțin.
În primul rând, trebuiesc adăugate adresele dotdeb în lista (locală) de depozite:

$sudo nano /etc/apt/sources.list

Și adăugam la final,


deb http://php53.dotdeb.org stable all
deb-src http://php53.dotdeb.org stable all

Apoi, trebuie adăugată și cheia de validare


$ sudo gpg --keyserver keys.gnupg.net --recv-key 89DF5277
$ gpg -a --export 89DF5277 | sudo apt-key add -

Actualizăm


$ sudo apt-get update
$ sudo apt-get upgrade

Și instalăm ce ne trebuie

$ sudo aptitude install php5 php5-cli php5-mysql libapache2-mod-php5

Am folosit aptitude după ce am citit prin comentariile și recomandările de la dotdeb despre probleleme avute de unii utlizatori cu apt-get (inclusiv în Debian). Nu știu de ce, nu mi se pare normal, însă nu am avut timp de prea multe teste.

Orice alte module suplimentare php pot fi apoi instalate folosind apt-get fără probleme (eu cel puțin nu am avut nici o problemă apoi să adaug alte pachete).

Leave a Reply

Your email address will not be published. Required fields are marked *

CommentLuv badge